CentOS 64-bit安装WPS

1. 安装32位开发库:
yum install xulrunner.i686
yum install libXtst.i686

2. 在官网下载 wps-office-8.1.0.3724-0.1.b1p2.i686.rpm
安装:rpm -ivh wps-office-8.1.0.3724-0.1.b1p2.i686.rpm

3.可能报的依赖错误:
error: Failed dependencies:
libmng.so.1 is needed by wps-office-8.1.0.3724-0.1.b1p2.i686
libpng12.so.0 is needed by wps-office-8.1.0.3724-0.1.b1p2.i686
libGLU.so.1 is needed by wps-office-8.1.0.3724-0.1.b1p2.i686

解决:
安装libmng: yum install libmng.i686
安装libpng12: 一般来说CentOS7已经有了较高版本的libpng,可以通过
ls -l /usr/lib/libpng*
看到,这时候用yum install 就会提示存在,这种情况可以从这个地址下载RPM包:libpng12-1.2.50-6.el7.i686.rpm
安装: rpm -ivh libpng12-1.2.50-6.el7.i686.rpm
安装mesa-libGLU: yum install mesa-libGLU.i686
如果出现个别依赖确实解决不了的,可以加上–nodeps试试:
rpm -ivh wps-office-8.1.0.3724-0.1.b1p2.i686.rpm --nodeps
安装成功后,按提示装字体。
附WPS for Linux截图:

转载请注明:梧桐树下 » CentOS 64-bit安装WPS

与本文相关文章

发表我的评论

取消评论
表情 插代码

Hi,您需要填写昵称和邮箱!

  • 必填项
  • 必填项